• Home
  • Uncategorized
  • error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”

error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”

While trying to do pip install pdftotext on Windows 10 x64, I got the error:

building 'pdftotext' extension
    error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools

Go to http://landinghub.visualstudio.com/visual-cpp-build-tools
Click on Download Build Tools for Visual Studio 2017 button:
Download Build Tools for Visual Studio 2017

Caution! It’s almost 1.2GB file size to download.

After that I got another error:

 pdftotext.cpp(3): fatal error C1083: Cannot open include file: 'poppler/cpp/poppler-document.h': No such file or directory
  error: command 'C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\BuildTools\\VC\\Tools\\MSVC\\14.13.26128\\bin\\HostX86\\x64\\cl.exe' failed with exit status 2

  ----------------------------------------
  Failed building wheel for pdftotext