Fatal error: Panel requires Ruby 1.8 (Ruby 1.9 is not supported).

You may face this error while installing openvz web panel.

Fatal error: Panel requires Ruby 1.8 (Ruby 1.9 is not supported).

Fix:

# update-alternatives --config ruby
There are 2 choices for the alternative ruby (providing /usr/bin/ruby).

  Selection    Path                Priority   Status
------------------------------------------------------------
* 0            /usr/bin/ruby1.9.1   51        auto mode
  1            /usr/bin/ruby1.8     50        manual mode
  2            /usr/bin/ruby1.9.1   51        manual mode

Press enter to keep the current choice[*], or type selection number: 1
update-alternatives: using /usr/bin/ruby1.8 to provide /usr/bin/ruby (ruby) in manual mode

And rerun the installer:

wget -O - http://ovz-web-panel.googlecode.com/svn/installer/ai.sh | sh

You are reading this post on Joel G Mathew’s tech blog. Joel's personal blog is the Eyrie, hosted here.