configure: error: XML::Parser perl module is required for intltool

To solve this, we need to install the module.

First locate the module’s package:

sudo apt-cache search perl XML::Parser
libxml-dom-perl - Perl module for building DOM Level 1 compliant doc structures
libxml-parser-perl - Perl module for parsing XML files
libxml-perl - Perl modules for working with XML
libxml-sax-expat-perl - Perl module for a SAX2 driver for Expat (XML::Parser)
libxml-twig-perl - Perl module for processing huge XML documents in tree mode
libdbix-xml-rdb-perl - perl module for creating XML from a DBI datasource
libmodule-versions-report-perl - Report versions of all modules in memory
libxml-autowriter-perl - Perl module to produce DOCTYPE-based XML output
libxml-checker-perl - Perl modules for validating XML
libxml-encoding-perl - Perl module for parsing encoding map XML files
libxml-filter-saxt-perl - Perl module for replicating events to several event handlers
libxml-handler-trees-perl - Perl module for building tree structures using PerlSAX handlers
libxml-parser-lite-tree-perl - lightweight XML tree builder
libxml-rsslite-perl - lightweight, "relaxed" RSS (and XML-ish) parser
libxml-simpleobject-enhanced-perl - Perl module which enhances libxml-simpleobject-perl
libxml-simpleobject-perl - Objectoriented Perl interface to a parsed XML::Parser tree
libxml-xslt-perl - Perl module for processing XSLT[/code]

So the package is:

libxml-parser-perl - Perl module for parsing XML files[/code]

Now install with

sudo apt-get install libxml-parser-perl[/code]


You are reading this post on Joel G Mathew’s tech blog. Joel's personal blog is the Eyrie, hosted here.

Comments

  1. Thank you for your post which has saved a huge amount of time.