• Home
  • Android
  • Missing requirement: Android Development Tools 16 requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found

Missing requirement: Android Development Tools 16 requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)
Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires ‘org.eclipse.wst.sse.core 0.0.0’ but it could not be found

 

This error cropped up while trying to install ADT Plugin for Eclipse on Ubuntu 11.10.

Trying to install Android SDK, I got an error from the SDK Manager :

Failed to fetch URL https://dl-ssl.google.com/android/repository/repository.xml, reason: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

Solution to that is to:

sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

Selection    Path                                      Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1061      auto mode
1            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1061      manual mode
2            /usr/lib/jvm/java-6-sun/jre/bin/java       63        manual mode

Press enter to keep the current choice[*], or type selection number: 1[/code]

Update on this: Did not work with the above...Anyone know a solution?